Архивы за месяц: Апрель 2016

Преобразование к типу Дата в 1С 8.2 и 8.3 в примерах

Описание типа данных «Дата»:
Значения данного типа содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до 0,1 миллисекунды.

Литералы:
Строка цифр, заключенная в одинарные кавычки вида: ‘ГГГГММДДччммсс’, где:

  • ГГГГ — четыре цифры года (включая тысячелетие и век);
  • ММ — две цифры месяца;
  • ДД — две цифры даты;
  • чч — две цифры часа (в 24-х часовом формате);
  • мм — две цифры минут;
  • сс — две цифры секунд;

Во встроенном языке в литерале типа Дата обязательно должно задаваться значение года, месяца и дня. Для задания даты соответствующей началу отсчета достаточно указать ‘00010101’. Допускается при указании литералов типа Дата опускать последние символы (секунды, минуты, часы и т.д.). Это означает, что данные параметры будут равны нулю (для времени) или единице (для даты). В литерале даты допускается использование различных разделителей.

Доступность: Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер). Возможен обмен с сервером. Сериализуется.
Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту, определяется в пространстве имен {http://www.w3.org/2001/XMLSchema}. Имя типа XDTO: может быть любым из перечисленных: dateTime, date, time.

Пример инициализации:

Дата = ‘20160121’; // 21.01.2016

Для преобразования строки в дату необходимо воспользоваться функцией Дата (Date).

Вариант синтаксиса: По строке

Синтаксис:

Дата (<Значение>)

Параметры:

<Значение> (обязательный)

Тип: Строка.
Исходное значение даты.
Строка должна содержать дату в локальном формате даты или в каноническом виде YYYYMMDDHHMMSS.

Описание варианта метода:

При преобразовании строка должна содержать дату в каноническом формате «ГГГГММДДччммсс» (см. раздел «Примитивные типы данных»).

Вариант синтаксиса: По составляющим

Синтаксис:

Дата(<Год>, <Месяц>, <День>, <Час>, <Минута>, <Секунда>)

Параметры:

<Год> (обязательный)

Тип: Число.
Год даты.

<Месяц> (обязательный)

Тип: Число.
Месяц даты.

<День> (обязательный)

Тип: Число.
День даты.

<Час> (необязательный)

Тип: Число.
Час даты.

<Минута> (необязательный)

Тип: Число.
Минута даты.

<Секунда> (необязательный)

Тип: Число.
Секунда даты.

Описание варианта метода:

Допускаются следующие формы задания параметров:

    • Дата(Год, Месяц, День);
    • Дата(Год, Месяц, День, Час, Минута, Секунда);

 Пример:

Дата = Дата(2016, 01, 21); // 21.01.2016

Возвращаемое значение:

Тип: Дата.

Описание:

Преобразует полученный параметр (параметры) в значение типа Дата.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

Восстановление уникальности кодов номенклатуры на примере УТ 10.3

Не редки случаи когда в базе 1С может наблюдаться нарушение уникальности  кодов элементов справочников, документов и т.д. Для проверки наличия данной проблемы можно воспользоваться одной из вариаций данного запроса:

Выбрать
РАЗЛИЧНЫЕ
Номенклатура1.Ссылка,
Номенклатура1.Код,
Номенклатура2.Ссылка,
Номенклатура2.Код
из
Справочник.Номенклатура КАК Номенклатура1
ЛЕВОЕ СОЕДИНЕНИЕ
Справочник.Номенклатура КАК Номенклатура2
ПО Номенклатура1.Код = Номенклатура2.Код
ГДЕ Номенклатура1.Ссылка <> Номенклатура2.Ссылка

Для восстановление уникальности кодов номенклатуры необходимо воспользоваться обработкой «Универсальные подбор и обработка объектов», которую можно скачать с сайта ИТС  .

Разберем работу данной обработки на примере задвоенности кодов справочника номенклатуры УТ 10.3.

Алгоритм. 

  1. Запускаем обработку в режиме «Предприятие» В поле «Объект поиска»  выбираем «Номенклатура» и нажимаем «Найти объекты».

Снимок

2. После того, как все объекты будут найдены необходимо перейти на вкладку «Обработки»  и выбрать «Перенумерация объектов»

Снимок2

3. Настроить параметры перенумерации (или оставить их по умолчанию) и нажать кнопку «Выполнить». Время процесса перенумерации зависит от количества задейтсвованных объектов.

Снимок3

4.  После завершение перенумерации отобразится соответствующее оповещение. Перенумерация завершена!

Добавление информационной базы 1С при клиент-серверном варианте работы

Добавить информационную базу в при клиент-серверном варианте работы 1С  можно 2-мя способами:

Первый способ.

  1. Заходим «Пуск»->»1С:Предприятие»->»Администрирование серверов 1С Предприятие».

1С администрирование

2. В открывшимся окне выбираем пункт «Информационные базы», щелкаем правой кнопкой мыши и выбираем «Создать»->»Информационная база»

1С инф

3. Далее вносим все необходимые данные.

Новая ИБ

4. Нажимаем «Ок».

5. Добавляем базу данных через платформу 1С привычным способом, указав, что база находится на сервере.

Второй способ.

  1. Запускаем платформу 1С, нажимаем  «Добавить».
  2. Выбираем «Создание новой информационной базы».

1113.  Далее выбираем будет ли информационная база создана из шаблона.

2224. Указываем имя информационной базы и то, что она будет создана на сервере.

333

5. В следующем окне заполняем поля также как и в первом способе

444 6. Нажимаем «Далее» и завершаем создание базы

Добавление дополнительных отчетов и обработок в тонком клиенте

Для того чтобы добавить дополнительную обработку или отчет в тонком клиенте нужно в модуле  объекта отчета или обработки прописать следующее.

  1. Для дополнительных обработок
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
    ПараметрыРегистрации.Версия = "1.0";
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = "Загрузка данных биллинга";
    НоваяКоманда.Идентификатор = "Биллинг";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    НоваяКоманда.ПоказыватьОповещение = Ложь;
    
    Возврат ПараметрыРегистрации;
    
КонецФункции

2. Для внешних отчетов

Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();
    ПараметрыРегистрации.Версия = "1.0";
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = "Отчет о списании материалов";
    НоваяКоманда.Идентификатор = "ОтчетОСписании";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    НоваяКоманда.ПоказыватьОповещение = Ложь;
    
    Возврат ПараметрыРегистрации;
    
КонецФункции

3. Для внешних печатных форм

Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
    ПараметрыРегистрации.Версия = "1.0";
    ПараметрыРегистрации.Назначение.Добавить("Документ.ТребованиеНакладная");
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = "Акт на списание материалов";
    НоваяКоманда.Идентификатор = "АктНаСписание";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    НоваяКоманда.ПоказыватьОповещение = Истина;
    НоваяКоманда.Модификатор = "ПечатьMXL";
    
    Возврат ПараметрыРегистрации;
    
КонецФункции